Tips & Guides

Here’s How You Can Check Which of Your Mac Apps Might Stop Working Soon

macOS High Sierra

Apple recently released a warning for developers on macOS 10.13.4 that the future update will not run 32-bit apps ‘without compromise’ and 64-bit will be required for both app submission and app updates.

MacOS High Sierra doesn’t actually change anything about the way a 32-bit app is run, but Apple is encouraging users of 32-bit apps to shift to 64-bit versions. Similar to iOS, the ultimate aim is to not support older 32-bit apps on macOS at all. To upgrade to new versions of affected apps, or to look for alternatives is highly recommended by Apple.

So, how to check which apps are currently 32-bit? Well, follow the steps mentioned below:

1)     Click on the Apple logo on the top left corner, hold down the Option key on your keyboard and click on System Information.

2)     On the left sidebar, scroll down to Software, expand the menu, and then select the Applications option. This may take a few moments.

3)     On the top, select the option to sort by 64-bit (Intel), and now you will have a list of apps that aren’t 64-bit (32-bit only). The 32-bit apps will be labelled as “No” instead of “Yes.”

Now you can use this information to see whether you will have any problems during the transition to 64-bit only software. If you have a speciality application that is 32-bit, you should check to see whether it is still being developed and will receive any updates.

Ironically, Apple’s DVD player and InkServer apps still lack the 64-bit support and some of Apple’s Mac App Store apps such as Compressor aren’t updated for 64-bit systems as well.

Unfortunately, the only solution left to this problem is to notify the developers behind the app, asking whether they are updating their app to a 64-bit version. Otherwise, they will probably be killed off by the newer version of macOS.

Luckily, there is no rush. These apps will work normally in High Sierra, will display warnings in the one after High Sierra, and will probably stop working after the release of after High Sierra OS. So, you have until late 2019. And if that time rolls out, you can still have an irreplaceable app if you refuse to update your current version of macOS; that will buy you some extra time. But in the end, it is all up to the developers to keep their apps updated in order to ensure they remain functional on the future versions of macOS.

Leave a Reply

Your email address will not be published. Required fields are marked *